Is Novi compatible with all browsers?

Is Novi compatible with all browsers?

Aimed at:¬† Edinburgh Napier’s staff & students

You can complete surveys from any browser but you must have one of the following browsers to design and edit surveys:

  • Internet Explorer version¬†8 or greater
  • Firefox version 3 or greater
  • Safari version 5 or greater
  • Chrome version 3 or greater
Attachments
There are no attachments for this article.
Related Articles RSS Feed
I need to create a survey but the "New Survey" icon is not visible when I log in to Novi, what do I do?
Viewed 14199 times since Thu, Feb 16, 2017
What is Novi Survey?
Viewed 14069 times since Thu, Feb 16, 2017
Where can I find help using Novi Survey?
Viewed 13986 times since Thu, Feb 16, 2017
I’ve deleted a question from my Novi survey, can I retrieve the answers for it?
Viewed 12555 times since Thu, Feb 16, 2017
MENU